This package requires php <=7.0.27 but your PHP version (7.0.30) does not satisfy that requirement.

This package requires php <=7.0.27 but your PHP version (7.0.30) does not satisfy that requirement.

At some projects when I tried:

php composer install

it gives me the following error:

– This package requires php <=7.0.27 but your PHP version (7.0.30) does not satisfy that requirement.

This is because in composer.json I had:  “php”: “<=7.0.27”,

The wright way is: “php”: “^7.0”,

After you make the change do not forget to delete the composer.lock: rm -rf composer.lock


Related Articles

php artisan tinker

This terminal command provides a REPL (Read-Eval-Print Loop) for PHP with your application’s settings already loaded: php artisan tinker You

Adding a column to an existing table – Laravel

For example we forgot to add the column password to the table users, and we already have inserted datas in